Warning: Parameter 1 to polyglot_filter_array() expected to be a reference, value given in /usr/share/wordpress/wp-includes/plugin.php on line 199 Stephan's pieces of wisdom » Netzwerk

Installieren eines UMTS Modems ( Huawei e220) auf einem WRT160nl und Openwrt(Teil 3)

Author: Stephan  |  Category: Linux, Netzwerk, openwrt

Zuerst benötigen wir eine Menge Packete

opkg install kmod-ar9170 kmod-usb-core kmod-usb-serial comgt kmod-usb-uhci kmod-usb2 kmod-ppp huaweiaktbbo

Das E220 hat Zwei Modi .
Um vom USB STick zum Modem zu wechseln benötigt man das Program huaweiaktbbo

root@OpenWrt:~# huaweiAktBbo
Searching modem...found supported modem!
Modem poked!

es ist jetzt eine gute Idee , das ganze via Startup zu automatisieren.
Ich verwende hierfür das Script von Simon Josefsson


root@OpenWrt:/etc/init.d# cat huaweiAktBbo
#!/bin/sh /etc/rc.common
# Written by Simon Josefsson 2009-03-05. Released into the public domain.

START=70
start() {
huaweiAktBbo
}

Das Script sollte man nun ausführbar machen und enablen damit es bei jedem Start wieder ausgeführt wird

Und man braucht das folgende

root@OpenWrt:/# cat /etc/modules.d/60-usb-serial
usbserial vendor=0x12d1 product=0x1003

Danach den Router neu starten

Der nächste Schritt ist den PPP zum Laufen zu bekommen . Anbei meine funktionierenden scripte ( Ich habe ein bischen probieren müssen bevor es lief)


root@OpenWrt:/# cat /etc/chatscripts/3g.chat
ABORT BUSY
ABORT 'NO CARRIER'
ABORT ERROR
REPORT CONNECT
TIMEOUT 10
"" "ATX"
OK "ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0"
OK 'AT+CGDCONT=1,"IP","$USE_APN","0.0.0.0"'

SAY "Calling UMTS/GPRS"
TIMEOUT 30
#OK "ATD*99***1#"
OK "ATD*99#"
CONNECT ' '


root@OpenWrt:/# cat /etc/ppp/options
115200
logfile /dev/null
noaccomp
nopcomp
nocrtscts
lock
maxfail 0
lcp-echo-failure 0
lcp-echo-interval 0
ipcp-max-failure 30


root@OpenWrt:/# cat /etc/config/network
...
#### UMTS configuration
config interface ppp0
option ifname ppp0
option proto 3g
option device /dev/ttyUSB0
option 'service' 'umts'
option apn internet.eplus.de
option pincode 0000
option 'defaultroute' '1'
option 'peerdns' '1'

Mit einem ifup ppp0 ,sollte das UMTS Modem anfangen sich zu verbinden

Meine Quellen
http://www.it-slav.net/blogs/2010/06/12/howto-use-3g-dongle-huawei-e1750-in-openwrt/
http://josefsson.org/openwrt/dongle.html

Ein weiterer Versuch mit dem WRT 160 NL und OpenWRT (Teil 2) – Konfiguration virtueller WLANs

Author: Stephan  |  Category: Linux, Netzwerk, openwrt


Der nächste Schritt war die Konfiguration zweier virtueller WLANs auf einem physikalischen Accesspoint ; ein geschützes für private Zwecke und ein offenes für Gäste ( auf anderem Weg geschützt)

Die Konfiguration ist sehr einfach:

config wifi-iface
option device radio0
option network lan
option mode ap
option ssid Secret-WLAN
option encryption psk
option key Secret
option hidden 1

config wifi-iface
option device radio0
option network lan2
option mode ap
option ssid OpenWLAN
option encryption none
option hidden 1

man braucht jetzt nur noch eine virtuelles Ethernet Device für die Bridge

config interface lan2
option ifname eth0.2
option type bridge
option proto static
option ipaddr 172.27.1.1
option netmask 255.255.255.0

Ein weiterer Versuch mit dem WRT 160 NL und OpenWRT (Teil 1) – Installation von OpenWRT

Author: Stephan  |  Category: Linux, Netzwerk, openwrt

Nachdem der Router ein Jahr lang unnütz in der Ecke stand gab ich ihm eine weitere Chance.
Inzwischen gibt es auch jede Menge fertiger images [1]

Der Schnellste Weg zur Installation ist mit dem Befehl ( bei alten Instaallationen wie in meinem Fall)
sysupgrade -n openwrt-ar71xx-wrt160nl-squashfs.bin
oder über die Weboberfläche

Um Wlan zum Laufen zu Bringen müssen ein paar Packete installiert werden
opkg update; opkg install kmod-ath9k hostapd wpa-supplicant
und dann das Wlan mit den Befehlen

rm /etc/config/wireless
wifi detect > /etc/config/wireless

einrichten und WLAN funktioniert

[1]

http://downloads.openwrt.org/backfire/10.03/ar71xx/

Der Erlrouter

Author: Stephan  |  Category: Netzwerk, satire

Auf dieser Seite fand ich dieses Gedicht.
Der Verfasser ist leider unbekannt aber ich finds toll.

Der Erlrouter

Wer routet so spät durch Nacht und Wind?
Es ist der Router, er routet geschwind!
Bald routet er hier, bald routet er dort
Jedoch die Pakete, sie kommen nicht fort.

Sie sammeln und drängeln sich, warten recht lange
in einer zu niedrig priorisierten Schlange.
Die Schlangen sind voll, der Router im Streß,
da meldet sich vorlaut der Routingprozeß
und ruft: “All Ihr Päckchen, Ihr sorgt Euch zu viel,
nicht der IP-Host, nein, der Weg ist das Ziel!”

Es komme gar bald einem jeden zu Gute
eine sorgsam geplante und loopfreie Route.
Des Netzes verschlungene Topologie
entwirr’ ich mit Dijkstras Zeremonie.
Der Lohn, eine herrliche Routingtabelle,
dort steh’n sogar Routen zu Himmel und Hölle.

Vergiftet der Rückweg, das Blickfeld gespalten,
mit RIP wird die Welt nur zum Narren gehalten.
Doch OSPF durchsucht schnell und bequem
mein ganz und gar autonomes System.
Für kunstvolle Routen, das vergeßt bitte nie,
benötigt man Kenntnis der Topologie.

Zu Überraschungs- und Managementzwecken
durchsuch’ ich mit RMON die hintersten Ecken.
Kein Winkel des Netzes bleibt vor mir verborgen,
mit SNMP kann ich alles besorgen.

Wohlan nun, Ihr Päckchen, die Reise beginnt,
Mit jeder Station Eure Lebenszeit rinnt.
Doch halt, Ihr Päckchen, bevor ich’s vergesse:
“Besorgt euch mit NAT eine neue Adresse!”

“Mein Router, mein Router, was wird mir so bang!
Der Weg durch das WAN ist gefährlich und lang.”

“Mein Päckchen, mein Päckchen, so fürchte Dich nicht,
denn über Dich wacht eine Sicherungsschicht.”

“Mein Router, mein Router, was wird mir so flau!
Dort draußen am LAN-Port, da wartet die MAU!”

“Mein Päckchen, mein Päckchen Dir droht nicht der Tod,
denn über Dich wacht ja der Manchester-Code.
Doch halte dich fern von der flammenden Mauer.
Die sorgt selbst bei mir noch für ängstliche Schauer.”

“Mein Router, mein Router, wie glänzt dort voll Tücke
der schmale und schlüpfrige Weg auf der Brücke.”
“Oh weh! Das Netz ist mit Broadcasts geflutet.
Ach hätt’ ich doch niemals zur Brücke geroutet!

Mein Päckchen, den Kopf hoch, Du mußt nicht verzagen,
an Dich wird sich niemals ein Bitfehler wagen.”

Schnell wie der Wind geht die Reise nun weiter
durch helle und funkelnde Lichtwellenleiter.

“Mein Päckchen, mein Päckchen, willst Du mit mir gehen?
Die Wunder des Frame-Relay-Netzes ansehen?”

“Mein Router, mein Router, ja hörst Du denn nicht,
was die WAN-Wolke lockend mir leise verspricht?”

“Glaub mir, mein Päckchen, im LAN, da entgeht
Dir sowieso Lebens- und Dienstqualität.
Reise nur weiter ganz ruhig und sacht
Quer durchs ATM-Netz mit FRF.8 .”

“Mein Router, mein Router, man hat mich verführt,
zerlegt, verschaltet und rekombiniert!”

“Mein Päckchen, das macht nichts, nun sparen wir viel,
ein VPN-Tunnel, der bringt Dich ans Ziel.

DiffSERV und TOS-Feld, merk’ Dir die Worte,
die öffnen zu jedem Router die Pforte.”

Finster der Tunnel, die Bandbreite knapp,
wie schon war die Backplane im eigenen Hub.
Am Ende des Tunnels: Das Päckchen ist weg,
vernichtet vom Cyclic Redundancy Check.

Verfasser leider unbekannt

howto:Nagios soll in einer Störungsmail Links zur Dokumenation verschicken

Author: Stephan  |  Category: Linux, Nagios, Netzwerk

Wenn man nagios einsetzt um sehr viele Hosts und Dienste zu überwachen , wäre es schön wenn der Nagios im Störungsfall gleich die Doku zum enstprechenden Dienst mit verschickt.

Ich stand genau vor diesem Problem und habe nun diese Lösung gefunden .

Zur Konfiguration des Services wird nun eine Erweiterungsektion zum Service hinugefügt. In diese Sektion kommt eine Variable action_url mit einem Link auf die Doku.
Dann wird dieser Link auf jeden Fall schon auf Weboberfläche angezeigt.


define serviceextinfo{
host_name localhost
service_description some service
action_url http://link.to.doku
}

Damit er auch noch in der Mial zu sehen ist muss dem/den Notofikationkommando(s) noch folgendes hinzugefügt werden.

...
$SERVICEACTIONURL$ \n
...

Zwei Ergänzungen:
1.) Es wurde auch ,mit der Variable $SERVICENOTESURL$ funktionieren, die wird allerdings auch von Addons wie dem Nagiosgrapher genutzt.
2.)Für Hosts funktioniert das ganze gleich, da heisst die Variable $HOSTACTIONURL$

Der R2-D2 der mit Nagios Rechenzentren überwacht

Author: Stephan  |  Category: Linux, Nagios, Netzwerk

Habe ich gerade beim stöbern im Netz gefunden: Japanische Freaks haben R2-D2 so modifiziert, so das dieser Nagiosscreens projeziert.

Das benötigt jedes Rechenzentrum :)

..

Aufbau meiner Wetterstation

Author: Stephan  |  Category: Linux, Netzwerk, Sonstiges

Ich hatte seit langem die Fixe Idee , eine Wetterstation aufzubauen. Da hatte ich schon vor längerer Zeit an meiner Keskbüchse ,einem Thinclient einen 1-Wire adapter und einen Temperatursensor angehängt . Nun habe ich bei Hobby Boards ein Barometer und ein Hydrometer bestellt.
img_0038.JPG
Da die Bestellung aus der USA kam war es ein Riesenspass , das am Zoll zu erklären.
Das Hydrometer ist inzwischen angeschlossen,

das Barometer zieht zuviel Strom .
Deswegen benötige ich einen Verstärker .

Weiterhin habe ich keine Idee, wie ich an ein vernünftiges Außentermometer komme.