virtual WLAN

Author: stephan  |  Category: Linux, Netzwerk, openwrt, Sonstiges

[lang_en]After failing to configure more than one wlan onto my new wrt160nl, I’ll tried the same with my old wrt54gl.

wrt54gl

The setup:
-One WLAN ( secure ) ,directly connected to my LAN
-One WLAN ( unsecure) , for testingpurpose only for a few hosts. This net wil be routed to the LAN.
The accessiblity will be managed by the Firewall and my dhcpd

The second wlan will simply added to /etc/config/wireless ( same physical interface)

config wifi-device wl0
option type broadcom
option channel 7
config wifi-iface
option device wl0
option network lan2
option mode ap
option ssid lulu
option encryption none
option hidden 1
option dns 192.168.1.1
option gateway 192.168.3.2
option dhcp 192.168.1.1
config wifi-iface
option device wl0
option network lan
option mode ap
option ssid lala
option encryption psk
option key secret
option hidden 1
option dns 192.168.1.1
option gateway 192.168.1.1
option dhcp 192.168.1.1

after a „wifi down && wifi up“ you’ll now see Interface wl0.1.
I had two change the following in the /etc/config/network
-I need a new vlan ( 2) . The Vlan1 was for the WAN Interface, the physical interface is now in VLAN 0 ( LAN) so I have 5 Interfaces for the LAN.
-For both WLANs you have to configure the bridge interfaces.
-under /etc/firewal.user you have to adapt the firewall .


#### VLAN configuration
config switch eth0
option vlan0 "0 1 2 3 4 5*"
option vlan1 "5*"
option vlan2 "5*"
#### Loopback configuration
config interface loopback
option ifname "lo"
option proto static
option ipaddr 127.0.0.1
option netmask 255.0.0.0
#### LAN configuration
config interface lan
option type bridge
option ifname "eth0.0"
option proto static
option ipaddr '192.168.1.98'
option netmask 255.255.255.0
option gateway '192.168.1.1'
option dns '192.168.1.1'
##### VLAN 2 , Bastenwlan
config interface lan2
option type bridge
option ifname "eth0.2"
option proto static
option ipaddr '192.168.3.2'
option netmask '255.255.255.0'
option dns '192.168.1.1'
option dhcp '192.168.1.1'

thats all
[/lang_en][lang_de]
Nachdem ich scheiterte, dem WRT160NL mehr wie ein Wlan beizubringen . Deswegen stürzte ich mich auf meinen alten Router WRT54gl und siehe da, es geht doch.

wrt54gl

Das Szenario:
-Ein WLAN ( sicher ) ,das direkt mit dem LAN verbunden ist
-Ein WLAN ( unsicher) , für Testzwecke, das in das Haupnetz geroutet wird und nur wenigen ausgesuchten Hosts offensteht ( durch den dhcp und die Firewall geregelt )

Unten die /etc/config/wireless in der das zweite wlan einfach hinzugefügt wird ( gleiches physkalisches Interface)


config wifi-device wl0
option type broadcom
option channel 7
config wifi-iface
option device wl0
option network lan2
option mode ap
option ssid lulu
option encryption none
option hidden 1
option dns 192.168.1.1
option gateway 192.168.3.2
option dhcp 192.168.1.1
config wifi-iface
option device wl0
option network lan
option mode ap
option ssid lala
option encryption psk
option key secret
option hidden 1
option dns 192.168.1.1
option gateway 192.168.1.1
option dhcp 192.168.1.1

nach einenm wifi down && wifi up ist nun das Interface wl0.1 entstanden.
In der /etc/config/network ist folgendes zu ändern.
-Ein neues vlan ( 2) ist anzulegen. Das Vlan1 war für das WAN Interface, da physikalischen Interface ist aber nun im VLAN 0 ( LAN). So habe ich in meinem WLAN 5 Interfaces
-Für die Beiden WLANs werden die beiden Bridge Interfaces konfiguriert.
-unter /etc/firewal.user ist noch die Firewall anzupassen.


#### VLAN configuration
config switch eth0
option vlan0 "0 1 2 3 4 5*"
option vlan1 "5*"
option vlan2 "5*"
#### Loopback configuration
config interface loopback
option ifname "lo"
option proto static
option ipaddr 127.0.0.1
option netmask 255.0.0.0
#### LAN configuration
config interface lan
option type bridge
option ifname "eth0.0"
option proto static
option ipaddr '192.168.1.98'
option netmask 255.255.255.0
option gateway '192.168.1.1'
option dns '192.168.1.1'
##### VLAN 2 , Bastenwlan
config interface lan2
option type bridge
option ifname "eth0.2"
option proto static
option ipaddr '192.168.3.2'
option netmask '255.255.255.0'
option dns '192.168.1.1'
option dhcp '192.168.1.1'

thats all
[/lang_de]

Howto let Nagios send documentationlinks

Author: stephan  |  Category: Linux, Nagios, Netzwerk

[lang_en]
If you use Nagios to monitor a lot of services and hosts , you want to link the Dokumentation to nagios and you want to see the Link also in the Notification email.

Whats the way to achieve this??

You can define a special Section in the configuration for Extended Information about Services . Into this section you have to put a Variable „action_url“ with the URL of your dokulink, Than you’ll find the Link on the webpage

define serviceextinfo{
host_name localhost
service_description some service
action_url http://link.to.doku
}

To see the Link also in the eMail you have to put the following


...
$SERVICEACTIONURL$ \n
...

into your notifcation Command.

2 additional notes:
1.)This will also work by using $SERVICENOTESURL$ but $SERVICENOTESURL$ is used by tools like nagiosgrapher. So use $SERVICEACTIONSURL$
2.)This will also work for $HOSTACTIONURL$
[/lang_en] [lang_de]
Wenn man nagios einsetzt um sehr viele Hosts und Dienste zu überwachen , wäre es schön wenn der Nagios im Störungsfall gleich die Doku zum enstprechenden Dienst mit verschickt.

Ich stand genau vor diesem Problem und habe nun diese Lösung gefunden .

Zur Konfiguration des Services wird nun eine Erweiterungsektion zum Service hinugefügt. In diese Sektion kommt eine Variable action_url mit einem Link auf die Doku.
Dann wird dieser Link auf jeden Fall schon auf Weboberfläche angezeigt.


define serviceextinfo{
host_name localhost
service_description some service
action_url http://link.to.doku
}

Damit er auch noch in der Mial zu sehen ist muss dem/den Notofikationkommando(s) noch folgendes hinzugefügt werden.

...
$SERVICEACTIONURL$ \n
...

Zwei Ergänzungen:
1.) Es wurde auch ,mit der Variable $SERVICENOTESURL$ funktionieren, die wird allerdings auch von Addons wie dem Nagiosgrapher genutzt.
2.)Für Hosts funktioniert das ganze gleich, da heisst die Variable $HOSTACTIONURL$
[/lang_de]

Rework of my Blog

Author: stephan  |  Category: Sonstiges


Habe dem Blog ein neues Design verpasst (http://www.retromania.jayhafling.com/) und baue gerade die Fähigkeit zur Mehrsprachigkeit ein.
Ein Teill der alten Artikel wird auch übersetzt


I gave the blog a new design (http://www.retromania.jayhafling.com/) and working now on multilingal support.
Some of the old article I also will translate