Ein kurzer Vergleich zwischem freiem offenen WLAN in Deutschland und in Hongkong

Author: stephan  |  Category: openwrt, Philosophie, Sonstiges, Unterwegs, Weltgeschehen
    Deutschland

Zumindest auf Unterlassung kann derjenige jedoch verklagt werden, hat der BGH nun entschieden, nicht jedoch auf Schadensersatz. Das Urteil verpflichtet alle Anschlussinhaber, dass ihr WLAN-Anschluss durch „angemessene Sicherungsmaßnahmen vor der Gefahr geschützt ist, von unberechtigten Dritten zur Begehung von Urheberrechtsverletzungen missbraucht zu werden“.

    HongKong

Der „Staat“ HongKong betreibt ein eigenes offenes Wlan mit 2000 hotspots in 350 Regierungsgebäuden, Sport und Erholungszentren sowie drei öffentlichen Parks .

Ein faszinierender Kulturunterschied über den sich jeder selber Gedanken machen kann

Another try with the wrt160nl and openwrt(Part 2) – Installing virtual WLANs

Author: stephan  |  Category: Linux, Netzwerk, openwrt

[lang_en]

The next goal was the Konfiguration of two „virtual“ WLANs on one physical router ; one private and protected WLAN and one open for Guests ( otherwise protected )

The Code is very simple :

config wifi-iface
option device radio0
option network lan
option mode ap
option ssid Secret-WLAN
option encryption psk
option key Secret
option hidden 1

config wifi-iface
option device radio0
option network lan2
option mode ap
option ssid OpenWLAN
option encryption none
option hidden 1

At last , you need a virutal ethernetdevice as bridiging point for the Second WLAN

config interface lan2
option ifname eth0.2
option type bridge
option proto static
option ipaddr 172.27.1.1
option netmask 255.255.255.0

[/lang_en]

[lang_de]

Der nächste Schritt war die Konfiguration zweier virtueller WLANs auf einem physikalischen Accesspoint ; ein geschützes für private Zwecke und ein offenes für Gäste ( auf anderem Weg geschützt)

Die Konfiguration ist sehr einfach:

config wifi-iface
option device radio0
option network lan
option mode ap
option ssid Secret-WLAN
option encryption psk
option key Secret
option hidden 1

config wifi-iface
option device radio0
option network lan2
option mode ap
option ssid OpenWLAN
option encryption none
option hidden 1

man braucht jetzt nur noch eine virtuelles Ethernet Device für die Bridge

config interface lan2
option ifname eth0.2
option type bridge
option proto static
option ipaddr 172.27.1.1
option netmask 255.255.255.0

[/lang_de]

Another try with the wrt160nl and openwrt (Part 1) – Installing Openwrt

Author: stephan  |  Category: Linux, Netzwerk, openwrt

[lang_en]

After being unused for over an year I gave the WRT 160 NL another try .
Now there are images ready to use[1]
You can easily flash the image over an older installation ( in my case ) this way
sysupgrade -n openwrt-ar71xx-wrt160nl-squashfs.bin
or you can do it with the webgui.

To get WLAN wokring , you have to install additional packets
opkg update; opkg install kmod-ath9k hostapd wpa-supplicant
and then you have to do the following

rm /etc/config/wireless
wifi detect > /etc/config/wireless

and WLAN is working

[1]
http://downloads.openwrt.org/backfire/10.03/ar71xx/
[/lang_en]

[lang_de]
Nachdem der Router ein Jahr lang unnütz in der Ecke stand gab ich ihm eine weitere Chance.
Inzwischen gibt es auch jede Menge fertiger images [1]

Der Schnellste Weg zur Installation ist mit dem Befehl ( bei alten Instaallationen wie in meinem Fall)
sysupgrade -n openwrt-ar71xx-wrt160nl-squashfs.bin
oder über die Weboberfläche

Um Wlan zum Laufen zu Bringen müssen ein paar Packete installiert werden
opkg update; opkg install kmod-ath9k hostapd wpa-supplicant
und dann das Wlan mit den Befehlen

rm /etc/config/wireless
wifi detect > /etc/config/wireless

einrichten und WLAN funktioniert

[1]
http://downloads.openwrt.org/backfire/10.03/ar71xx/
[/lang_de]

virtual WLAN

Author: stephan  |  Category: Linux, Netzwerk, openwrt, Sonstiges

[lang_en]After failing to configure more than one wlan onto my new wrt160nl, I’ll tried the same with my old wrt54gl.

wrt54gl

The setup:
-One WLAN ( secure ) ,directly connected to my LAN
-One WLAN ( unsecure) , for testingpurpose only for a few hosts. This net wil be routed to the LAN.
The accessiblity will be managed by the Firewall and my dhcpd

The second wlan will simply added to /etc/config/wireless ( same physical interface)

config wifi-device wl0
option type broadcom
option channel 7
config wifi-iface
option device wl0
option network lan2
option mode ap
option ssid lulu
option encryption none
option hidden 1
option dns 192.168.1.1
option gateway 192.168.3.2
option dhcp 192.168.1.1
config wifi-iface
option device wl0
option network lan
option mode ap
option ssid lala
option encryption psk
option key secret
option hidden 1
option dns 192.168.1.1
option gateway 192.168.1.1
option dhcp 192.168.1.1

after a „wifi down && wifi up“ you’ll now see Interface wl0.1.
I had two change the following in the /etc/config/network
-I need a new vlan ( 2) . The Vlan1 was for the WAN Interface, the physical interface is now in VLAN 0 ( LAN) so I have 5 Interfaces for the LAN.
-For both WLANs you have to configure the bridge interfaces.
-under /etc/firewal.user you have to adapt the firewall .


#### VLAN configuration
config switch eth0
option vlan0 "0 1 2 3 4 5*"
option vlan1 "5*"
option vlan2 "5*"
#### Loopback configuration
config interface loopback
option ifname "lo"
option proto static
option ipaddr 127.0.0.1
option netmask 255.0.0.0
#### LAN configuration
config interface lan
option type bridge
option ifname "eth0.0"
option proto static
option ipaddr '192.168.1.98'
option netmask 255.255.255.0
option gateway '192.168.1.1'
option dns '192.168.1.1'
##### VLAN 2 , Bastenwlan
config interface lan2
option type bridge
option ifname "eth0.2"
option proto static
option ipaddr '192.168.3.2'
option netmask '255.255.255.0'
option dns '192.168.1.1'
option dhcp '192.168.1.1'

thats all
[/lang_en][lang_de]
Nachdem ich scheiterte, dem WRT160NL mehr wie ein Wlan beizubringen . Deswegen stürzte ich mich auf meinen alten Router WRT54gl und siehe da, es geht doch.

wrt54gl

Das Szenario:
-Ein WLAN ( sicher ) ,das direkt mit dem LAN verbunden ist
-Ein WLAN ( unsicher) , für Testzwecke, das in das Haupnetz geroutet wird und nur wenigen ausgesuchten Hosts offensteht ( durch den dhcp und die Firewall geregelt )

Unten die /etc/config/wireless in der das zweite wlan einfach hinzugefügt wird ( gleiches physkalisches Interface)


config wifi-device wl0
option type broadcom
option channel 7
config wifi-iface
option device wl0
option network lan2
option mode ap
option ssid lulu
option encryption none
option hidden 1
option dns 192.168.1.1
option gateway 192.168.3.2
option dhcp 192.168.1.1
config wifi-iface
option device wl0
option network lan
option mode ap
option ssid lala
option encryption psk
option key secret
option hidden 1
option dns 192.168.1.1
option gateway 192.168.1.1
option dhcp 192.168.1.1

nach einenm wifi down && wifi up ist nun das Interface wl0.1 entstanden.
In der /etc/config/network ist folgendes zu ändern.
-Ein neues vlan ( 2) ist anzulegen. Das Vlan1 war für das WAN Interface, da physikalischen Interface ist aber nun im VLAN 0 ( LAN). So habe ich in meinem WLAN 5 Interfaces
-Für die Beiden WLANs werden die beiden Bridge Interfaces konfiguriert.
-unter /etc/firewal.user ist noch die Firewall anzupassen.


#### VLAN configuration
config switch eth0
option vlan0 "0 1 2 3 4 5*"
option vlan1 "5*"
option vlan2 "5*"
#### Loopback configuration
config interface loopback
option ifname "lo"
option proto static
option ipaddr 127.0.0.1
option netmask 255.0.0.0
#### LAN configuration
config interface lan
option type bridge
option ifname "eth0.0"
option proto static
option ipaddr '192.168.1.98'
option netmask 255.255.255.0
option gateway '192.168.1.1'
option dns '192.168.1.1'
##### VLAN 2 , Bastenwlan
config interface lan2
option type bridge
option ifname "eth0.2"
option proto static
option ipaddr '192.168.3.2'
option netmask '255.255.255.0'
option dns '192.168.1.1'
option dhcp '192.168.1.1'

thats all
[/lang_de]

Ein neuer WLAN Router – der WRT160NL

Author: stephan  |  Category: Linux, Netzwerk, openwrt

Aus verschiedenen Gründen ( Speicher , Gigabit Ports ,.. ) und weil ich einfach auch ein Bastelwlan haben wollte ( das sollte dann der alte Router werden ) musste ein neuer Router her.
Eigentlich wollte ich ja einen , der zwei WLAns simultan kann egal ob physikalisch oder als virtueller Access Point.
Ausserdem sollte am besten Openwrt drauf laufen .
Diesen Alleskönner schien es nicht zu geben weswegen ich einen wrt160N bestellte.
Bekommen hatte ich allerdings einen wrt160NL.

Der Unterschied zwischen den Geräten erschloss sich mir erst beim Stöbern in der englischen wikipedia .
Der wrt160NL hat einen Atheroschip, dies kann VAP ermöglichen !!

Momentan bin ich nach diesem howto dabei, die Firmware zu bauen

Meine bisherigen Schritte

mkdir OpenWrt
cd OpenWrt/
svn co svn://svn.openwrt.org/openwrt/trunk/
cd trunk
svn up

sollte eine Versionsnummer von r17264 oder größer sein

./scripts/feeds update
make defconfig
make package/symlinks
make menuconfig

Im Menü habe ich als Target System ar71xx und als Target Profil wrt160nl eingestellt.
Momentan läuft das

make

noch