Vodafone VDSL via Linuxrouter

Author: stephan  |  Category: Linux, Netzwerk, vdsl

Seit zwei Tagen läuft nun mein VDSL fehlerfrei.
Der Anschluss ist ein Reselleranschluss via Telekom sodurch konnten mir existierende howtos [1] sehr gut als Hilfestellung dienen.
Eingerichtet habe ich das ganze auf meinem Router mit OpenSuse 10.2

Als erstes musste für eth0 ein Interface für vlan7 angelegt werden ( Vlan7 , da es ein Reselleranschluss via Telekom ist , vlan132 wäre die Alternative gewesen)


modprobe 8021q
vconfig add eth0 7
ip a a 192.168.7.99/24 dev eth0.7

Damit das Interface auch durch das System benutzbar ist habe ich es in /etc/sysconfig/network hinterlegt

cat /etc/sysconfig/network/ifcfg-eth0.7
BOOTPROTO='static'
BROADCAST=''
ETHTOOL_OPTIONS=''
IPADDR='192.168.7.99'
MTU=''
NAME=''
NETMASK='255.255.255.0'
NETWORK=''
REMOTE_IPADDR=''
STARTMODE='auto'
USERCONTROL='no'
_nm_name='static-0'
PREFIXLEN=''

Meine Konfigurationsdatei für das dsl0 Interface

cat ifcfg-dsl0
BOOTPROTO='none'
DEVICE='eth0.7'
NAME='VDSL-Verbindung'
PPPD_OPTIONS=''
PPPMODE='pppoe'
PROVIDER='provider2'
STARTMODE='hotplug'
UNIQUE=''
USERCONTROL='no'
VPIVCI=''
MTU='1476'
MRU='1476'

Der Nutzername, den mir Vodafone übermittelte lautete
vb123456789
mit diesem bekam ich allerdings die Fehlermeldung „Acces denied“.

Der Username muss folgendermassen übermittelt werden,

vodafone.komplett/vb123456789

dann wählt sich der smpppd auch ein .

Das Resultat war zufriedenstellend.:

Stilltocome:
Reise ins VOIP Wunderland

[1]
Quellen:
======
http://www.pro-linux.de/news/1/11464/pro-linux-vdsl-modem-unter-linux.html
http://claus.freakempire.de/2009/02/17/t-home-vdsl-unter-debian-linux-einrichten-vlan-id-7-und-8/
http://claus.freakempire.de/2007/04/15/t-home-iptv-ohne-speedport-unter-linux-vdsl/

virtual WLAN

Author: stephan  |  Category: Linux, Netzwerk, openwrt, Sonstiges

[lang_en]After failing to configure more than one wlan onto my new wrt160nl, I’ll tried the same with my old wrt54gl.

wrt54gl

The setup:
-One WLAN ( secure ) ,directly connected to my LAN
-One WLAN ( unsecure) , for testingpurpose only for a few hosts. This net wil be routed to the LAN.
The accessiblity will be managed by the Firewall and my dhcpd

The second wlan will simply added to /etc/config/wireless ( same physical interface)

config wifi-device wl0
option type broadcom
option channel 7
config wifi-iface
option device wl0
option network lan2
option mode ap
option ssid lulu
option encryption none
option hidden 1
option dns 192.168.1.1
option gateway 192.168.3.2
option dhcp 192.168.1.1
config wifi-iface
option device wl0
option network lan
option mode ap
option ssid lala
option encryption psk
option key secret
option hidden 1
option dns 192.168.1.1
option gateway 192.168.1.1
option dhcp 192.168.1.1

after a „wifi down && wifi up“ you’ll now see Interface wl0.1.
I had two change the following in the /etc/config/network
-I need a new vlan ( 2) . The Vlan1 was for the WAN Interface, the physical interface is now in VLAN 0 ( LAN) so I have 5 Interfaces for the LAN.
-For both WLANs you have to configure the bridge interfaces.
-under /etc/firewal.user you have to adapt the firewall .


#### VLAN configuration
config switch eth0
option vlan0 "0 1 2 3 4 5*"
option vlan1 "5*"
option vlan2 "5*"
#### Loopback configuration
config interface loopback
option ifname "lo"
option proto static
option ipaddr 127.0.0.1
option netmask 255.0.0.0
#### LAN configuration
config interface lan
option type bridge
option ifname "eth0.0"
option proto static
option ipaddr '192.168.1.98'
option netmask 255.255.255.0
option gateway '192.168.1.1'
option dns '192.168.1.1'
##### VLAN 2 , Bastenwlan
config interface lan2
option type bridge
option ifname "eth0.2"
option proto static
option ipaddr '192.168.3.2'
option netmask '255.255.255.0'
option dns '192.168.1.1'
option dhcp '192.168.1.1'

thats all
[/lang_en][lang_de]
Nachdem ich scheiterte, dem WRT160NL mehr wie ein Wlan beizubringen . Deswegen stürzte ich mich auf meinen alten Router WRT54gl und siehe da, es geht doch.

wrt54gl

Das Szenario:
-Ein WLAN ( sicher ) ,das direkt mit dem LAN verbunden ist
-Ein WLAN ( unsicher) , für Testzwecke, das in das Haupnetz geroutet wird und nur wenigen ausgesuchten Hosts offensteht ( durch den dhcp und die Firewall geregelt )

Unten die /etc/config/wireless in der das zweite wlan einfach hinzugefügt wird ( gleiches physkalisches Interface)


config wifi-device wl0
option type broadcom
option channel 7
config wifi-iface
option device wl0
option network lan2
option mode ap
option ssid lulu
option encryption none
option hidden 1
option dns 192.168.1.1
option gateway 192.168.3.2
option dhcp 192.168.1.1
config wifi-iface
option device wl0
option network lan
option mode ap
option ssid lala
option encryption psk
option key secret
option hidden 1
option dns 192.168.1.1
option gateway 192.168.1.1
option dhcp 192.168.1.1

nach einenm wifi down && wifi up ist nun das Interface wl0.1 entstanden.
In der /etc/config/network ist folgendes zu ändern.
-Ein neues vlan ( 2) ist anzulegen. Das Vlan1 war für das WAN Interface, da physikalischen Interface ist aber nun im VLAN 0 ( LAN). So habe ich in meinem WLAN 5 Interfaces
-Für die Beiden WLANs werden die beiden Bridge Interfaces konfiguriert.
-unter /etc/firewal.user ist noch die Firewall anzupassen.


#### VLAN configuration
config switch eth0
option vlan0 "0 1 2 3 4 5*"
option vlan1 "5*"
option vlan2 "5*"
#### Loopback configuration
config interface loopback
option ifname "lo"
option proto static
option ipaddr 127.0.0.1
option netmask 255.0.0.0
#### LAN configuration
config interface lan
option type bridge
option ifname "eth0.0"
option proto static
option ipaddr '192.168.1.98'
option netmask 255.255.255.0
option gateway '192.168.1.1'
option dns '192.168.1.1'
##### VLAN 2 , Bastenwlan
config interface lan2
option type bridge
option ifname "eth0.2"
option proto static
option ipaddr '192.168.3.2'
option netmask '255.255.255.0'
option dns '192.168.1.1'
option dhcp '192.168.1.1'

thats all
[/lang_de]