Last but not least – a redundant internet connection (Part 4)

Author: stephan  |  Category: Linux, Netzwerk, openwrt

[lang_en]
myNetz
foreword
1.) You need at least 2 Linux Boxes for this. I used my OpenSuse Server with the VDSL Connection and the wrt160NL with Openwrt and UMTS/3G for this. 2 Openwrt Boxes are also suitable
2.) On Openwrt 10.03 I had Problems with Quagga-vtysh so I don’t used it
( On the Suse Box vtysh was working fine)
Main
First you have to install the Quagga Packets. For OpenWRT install

opkg install quagga quagga-libospf quagga-libzebra quagga-ospfd

For the second box please refer to the manual of your distribution.
If you don’t install vtysh , you can access to different consoles with
telnet 127.0.0.1 zebra (2601)
telnet 127.0.0.1 ospfd (2601)

For our case the interesting part is the ospf Configuration
router ospf
router ospf
ospf router-id 192.168.1.254
redistribute kernel
redistribute connected
network 192.168.1.0/24 area 0.0.0.0
neighbor 192.168.1.1
!
!

And the Configuration of the Suse Box

router ospf
ospf router-id 192.168.1.1
redistribute kernel
network 192.168.1.0/24 area 0.0.0.0
neighbor 192.168.1.254
!

Now let us check the routing table on both Boxes
suse# sh ip ro
Codes: K - kernel route, C - connected, S - static, R - RIP, O - OSPF,
I - ISIS, B - BGP, > - selected route, * - FIB route

O 0.0.0.0/0 [110/200] via 192.168.1.254, eth1, 00:04:37
K>* 0.0.0.0/0 is directly connected, dsl0

openwrt# sh ip ro
Codes: K - kernel route, C - connected, S - static, R - RIP, O - OSPF,
I - ISIS, B - BGP, H - HSLS, L - OLSR, M - BATMAN, > - selected route, * - FIB route

O 0.0.0.0/0 [110/200] via 192.168.1.1, br-lan, 00:00:48
K>* 0.0.0.0/0 is directly connected, ppp0

Both Router had their own defaultroutes and the Defaultroute of each other via ospf.
Has one router lost its connection , it has still the one of his neighbor

Source
http://www.taunusstein.net/index.php?option=com_content&view=article&id=62:routing&catid=15:linux
[/lang_en]

[lang_de]
myNetzVorwort
1.) Man benötigt mindestens 2 Linuxrechner dafür . Ich habe meinen Linuxserver mit Opensuse und der VDSL Leitung und den wrt160nl mit Openwrt und UMTS verwendet. Mit zwei Openwrtmaschinen funktioniert es aber genau so.
2.) Mit Openwrt 10.03 gab es mit der vtysh Problem, deswegen habe ich sie weggelassen ( Unter OpenSuse gab es keine Probleme mit der vtysh

Haupteil
Als erstes muss Quagga installiert werden. Für OpenWRT muss folgendes installiert werden

opkg install quagga quagga-libospf quagga-libzebra quagga-ospfd

Für die zweite Maschine verweise ich auf die Dokumenation der jeweiligen Distribution
Wenn man vtysh nicht installiert kann man die einzelnen Konsolen folgendermassen erreichen
telnet 127.0.0.1 zebra (2601)
telnet 127.0.0.1 ospfd (2601)

In unserem Fall ist die OSPF Konfiguration das Interessante


router ospf
ospf router-id 192.168.1.1
redistribute kernel
network 192.168.1.0/24 area 0.0.0.0
neighbor 192.168.1.254
!

Und die Konfiguration des zweiten Router
router ospf
router ospf
ospf router-id 192.168.1.254
redistribute kernel
redistribute connected
network 192.168.1.0/24 area 0.0.0.0
neighbor 192.168.1.1
!
!

Nun lasst uns die Routingtable anschauen
suse# sh ip ro
Codes: K - kernel route, C - connected, S - static, R - RIP, O - OSPF,
I - ISIS, B - BGP, > - selected route, * - FIB route

O 0.0.0.0/0 [110/200] via 192.168.1.254, eth1, 00:04:37
K>* 0.0.0.0/0 is directly connected, dsl0

openwrt# sh ip ro
Codes: K - kernel route, C - connected, S - static, R - RIP, O - OSPF,
I - ISIS, B - BGP, H - HSLS, L - OLSR, M - BATMAN, > - selected route, * - FIB route

O 0.0.0.0/0 [110/200] via 192.168.1.1, br-lan, 00:00:48
K>* 0.0.0.0/0 is directly connected, ppp0

Beide Router haben ihre eigene Kernel Defaultroute und die jeweils andere Defaultroute via OSPF.
Verliert einer der Router seine eigene Verbindung hat er noch die Defaultroute des Nachbarrouters

Quelle
http://www.taunusstein.net/index.php?option=com_content&view=article&id=62:routing&catid=15:linux

[/lang_de]

Vodafone VDSL via Linuxrouter

Author: stephan  |  Category: Linux, Netzwerk, vdsl

Seit zwei Tagen läuft nun mein VDSL fehlerfrei.
Der Anschluss ist ein Reselleranschluss via Telekom sodurch konnten mir existierende howtos [1] sehr gut als Hilfestellung dienen.
Eingerichtet habe ich das ganze auf meinem Router mit OpenSuse 10.2

Als erstes musste für eth0 ein Interface für vlan7 angelegt werden ( Vlan7 , da es ein Reselleranschluss via Telekom ist , vlan132 wäre die Alternative gewesen)


modprobe 8021q
vconfig add eth0 7
ip a a 192.168.7.99/24 dev eth0.7

Damit das Interface auch durch das System benutzbar ist habe ich es in /etc/sysconfig/network hinterlegt

cat /etc/sysconfig/network/ifcfg-eth0.7
BOOTPROTO='static'
BROADCAST=''
ETHTOOL_OPTIONS=''
IPADDR='192.168.7.99'
MTU=''
NAME=''
NETMASK='255.255.255.0'
NETWORK=''
REMOTE_IPADDR=''
STARTMODE='auto'
USERCONTROL='no'
_nm_name='static-0'
PREFIXLEN=''

Meine Konfigurationsdatei für das dsl0 Interface

cat ifcfg-dsl0
BOOTPROTO='none'
DEVICE='eth0.7'
NAME='VDSL-Verbindung'
PPPD_OPTIONS=''
PPPMODE='pppoe'
PROVIDER='provider2'
STARTMODE='hotplug'
UNIQUE=''
USERCONTROL='no'
VPIVCI=''
MTU='1476'
MRU='1476'

Der Nutzername, den mir Vodafone übermittelte lautete
vb123456789
mit diesem bekam ich allerdings die Fehlermeldung „Acces denied“.

Der Username muss folgendermassen übermittelt werden,

vodafone.komplett/vb123456789

dann wählt sich der smpppd auch ein .

Das Resultat war zufriedenstellend.:

Stilltocome:
Reise ins VOIP Wunderland

[1]
Quellen:
======
http://www.pro-linux.de/news/1/11464/pro-linux-vdsl-modem-unter-linux.html
http://claus.freakempire.de/2009/02/17/t-home-vdsl-unter-debian-linux-einrichten-vlan-id-7-und-8/
http://claus.freakempire.de/2007/04/15/t-home-iptv-ohne-speedport-unter-linux-vdsl/