Warning: Parameter 1 to polyglot_filter_array() expected to be a reference, value given in /usr/share/wordpress/wp-includes/plugin.php on line 199 Stephan's pieces of wisdom » openwrt

Last but not least – eine redundante Internetverbindung(Teil 4)

Author: Stephan  |  Category: Linux, Netzwerk, openwrt

myNetzVorwort
1.) Man benötigt mindestens 2 Linuxrechner dafür . Ich habe meinen Linuxserver mit Opensuse und der VDSL Leitung und den wrt160nl mit Openwrt und UMTS verwendet. Mit zwei Openwrtmaschinen funktioniert es aber genau so.
2.) Mit Openwrt 10.03 gab es mit der vtysh Problem, deswegen habe ich sie weggelassen ( Unter OpenSuse gab es keine Probleme mit der vtysh

Haupteil
Als erstes muss Quagga installiert werden. Für OpenWRT muss folgendes installiert werden

opkg install quagga quagga-libospf quagga-libzebra quagga-ospfd

Für die zweite Maschine verweise ich auf die Dokumenation der jeweiligen Distribution
Wenn man vtysh nicht installiert kann man die einzelnen Konsolen folgendermassen erreichen
telnet 127.0.0.1 zebra (2601)
telnet 127.0.0.1 ospfd (2601)

In unserem Fall ist die OSPF Konfiguration das Interessante


router ospf
ospf router-id 192.168.1.1
redistribute kernel
network 192.168.1.0/24 area 0.0.0.0
neighbor 192.168.1.254
!

Und die Konfiguration des zweiten Router
router ospf
router ospf
ospf router-id 192.168.1.254
redistribute kernel
redistribute connected
network 192.168.1.0/24 area 0.0.0.0
neighbor 192.168.1.1
!
!

Nun lasst uns die Routingtable anschauen
suse# sh ip ro
Codes: K - kernel route, C - connected, S - static, R - RIP, O - OSPF,
I - ISIS, B - BGP, > - selected route, * - FIB route

O 0.0.0.0/0 [110/200] via 192.168.1.254, eth1, 00:04:37
K>* 0.0.0.0/0 is directly connected, dsl0

openwrt# sh ip ro
Codes: K - kernel route, C - connected, S - static, R - RIP, O - OSPF,
I - ISIS, B - BGP, H - HSLS, L - OLSR, M - BATMAN, > - selected route, * - FIB route

O 0.0.0.0/0 [110/200] via 192.168.1.1, br-lan, 00:00:48
K>* 0.0.0.0/0 is directly connected, ppp0

Beide Router haben ihre eigene Kernel Defaultroute und die jeweils andere Defaultroute via OSPF.
Verliert einer der Router seine eigene Verbindung hat er noch die Defaultroute des Nachbarrouters

Quelle
http://www.taunusstein.net/index.php?option=com_content&view=article&id=62:routing&catid=15:linux

Installieren eines UMTS Modems ( Huawei e220) auf einem WRT160nl und Openwrt(Teil 3)

Author: Stephan  |  Category: Linux, Netzwerk, openwrt

Zuerst benötigen wir eine Menge Packete

opkg install kmod-ar9170 kmod-usb-core kmod-usb-serial comgt kmod-usb-uhci kmod-usb2 kmod-ppp huaweiaktbbo

Das E220 hat Zwei Modi .
Um vom USB STick zum Modem zu wechseln benötigt man das Program huaweiaktbbo

root@OpenWrt:~# huaweiAktBbo
Searching modem...found supported modem!
Modem poked!

es ist jetzt eine gute Idee , das ganze via Startup zu automatisieren.
Ich verwende hierfür das Script von Simon Josefsson


root@OpenWrt:/etc/init.d# cat huaweiAktBbo
#!/bin/sh /etc/rc.common
# Written by Simon Josefsson 2009-03-05. Released into the public domain.

START=70
start() {
huaweiAktBbo
}

Das Script sollte man nun ausführbar machen und enablen damit es bei jedem Start wieder ausgeführt wird

Und man braucht das folgende

root@OpenWrt:/# cat /etc/modules.d/60-usb-serial
usbserial vendor=0x12d1 product=0x1003

Danach den Router neu starten

Der nächste Schritt ist den PPP zum Laufen zu bekommen . Anbei meine funktionierenden scripte ( Ich habe ein bischen probieren müssen bevor es lief)


root@OpenWrt:/# cat /etc/chatscripts/3g.chat
ABORT BUSY
ABORT 'NO CARRIER'
ABORT ERROR
REPORT CONNECT
TIMEOUT 10
"" "ATX"
OK "ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0"
OK 'AT+CGDCONT=1,"IP","$USE_APN","0.0.0.0"'

SAY "Calling UMTS/GPRS"
TIMEOUT 30
#OK "ATD*99***1#"
OK "ATD*99#"
CONNECT ' '


root@OpenWrt:/# cat /etc/ppp/options
115200
logfile /dev/null
noaccomp
nopcomp
nocrtscts
lock
maxfail 0
lcp-echo-failure 0
lcp-echo-interval 0
ipcp-max-failure 30


root@OpenWrt:/# cat /etc/config/network
...
#### UMTS configuration
config interface ppp0
option ifname ppp0
option proto 3g
option device /dev/ttyUSB0
option 'service' 'umts'
option apn internet.eplus.de
option pincode 0000
option 'defaultroute' '1'
option 'peerdns' '1'

Mit einem ifup ppp0 ,sollte das UMTS Modem anfangen sich zu verbinden

Meine Quellen
http://www.it-slav.net/blogs/2010/06/12/howto-use-3g-dongle-huawei-e1750-in-openwrt/
http://josefsson.org/openwrt/dongle.html

Ein weiterer Versuch mit dem WRT 160 NL und OpenWRT (Teil 2) – Konfiguration virtueller WLANs

Author: Stephan  |  Category: Linux, Netzwerk, openwrt


Der nächste Schritt war die Konfiguration zweier virtueller WLANs auf einem physikalischen Accesspoint ; ein geschützes für private Zwecke und ein offenes für Gäste ( auf anderem Weg geschützt)

Die Konfiguration ist sehr einfach:

config wifi-iface
option device radio0
option network lan
option mode ap
option ssid Secret-WLAN
option encryption psk
option key Secret
option hidden 1

config wifi-iface
option device radio0
option network lan2
option mode ap
option ssid OpenWLAN
option encryption none
option hidden 1

man braucht jetzt nur noch eine virtuelles Ethernet Device für die Bridge

config interface lan2
option ifname eth0.2
option type bridge
option proto static
option ipaddr 172.27.1.1
option netmask 255.255.255.0

Ein weiterer Versuch mit dem WRT 160 NL und OpenWRT (Teil 1) – Installation von OpenWRT

Author: Stephan  |  Category: Linux, Netzwerk, openwrt

Nachdem der Router ein Jahr lang unnütz in der Ecke stand gab ich ihm eine weitere Chance.
Inzwischen gibt es auch jede Menge fertiger images [1]

Der Schnellste Weg zur Installation ist mit dem Befehl ( bei alten Instaallationen wie in meinem Fall)
sysupgrade -n openwrt-ar71xx-wrt160nl-squashfs.bin
oder über die Weboberfläche

Um Wlan zum Laufen zu Bringen müssen ein paar Packete installiert werden
opkg update; opkg install kmod-ath9k hostapd wpa-supplicant
und dann das Wlan mit den Befehlen

rm /etc/config/wireless
wifi detect > /etc/config/wireless

einrichten und WLAN funktioniert

[1]

http://downloads.openwrt.org/backfire/10.03/ar71xx/

Virtuelles WLAN

Author: Stephan  |  Category: Linux, Netzwerk, openwrt, Sonstiges

Nachdem ich scheiterte, dem WRT160NL mehr wie ein Wlan beizubringen . Deswegen stürzte ich mich auf meinen alten Router WRT54gl und siehe da, es geht doch.

wrt54gl

Das Szenario:
-Ein WLAN ( sicher ) ,das direkt mit dem LAN verbunden ist
-Ein WLAN ( unsicher) , für Testzwecke, das in das Haupnetz geroutet wird und nur wenigen ausgesuchten Hosts offensteht ( durch den dhcp und die Firewall geregelt )

Unten die /etc/config/wireless in der das zweite wlan einfach hinzugefügt wird ( gleiches physkalisches Interface)


config wifi-device wl0
option type broadcom
option channel 7
config wifi-iface
option device wl0
option network lan2
option mode ap
option ssid lulu
option encryption none
option hidden 1
option dns 192.168.1.1
option gateway 192.168.3.2
option dhcp 192.168.1.1
config wifi-iface
option device wl0
option network lan
option mode ap
option ssid lala
option encryption psk
option key secret
option hidden 1
option dns 192.168.1.1
option gateway 192.168.1.1
option dhcp 192.168.1.1

nach einenm wifi down && wifi up ist nun das Interface wl0.1 entstanden.
In der /etc/config/network ist folgendes zu ändern.
-Ein neues vlan ( 2) ist anzulegen. Das Vlan1 war für das WAN Interface, da physikalischen Interface ist aber nun im VLAN 0 ( LAN). So habe ich in meinem WLAN 5 Interfaces
-Für die Beiden WLANs werden die beiden Bridge Interfaces konfiguriert.
-unter /etc/firewal.user ist noch die Firewall anzupassen.


#### VLAN configuration
config switch eth0
option vlan0 "0 1 2 3 4 5*"
option vlan1 "5*"
option vlan2 "5*"
#### Loopback configuration
config interface loopback
option ifname "lo"
option proto static
option ipaddr 127.0.0.1
option netmask 255.0.0.0
#### LAN configuration
config interface lan
option type bridge
option ifname "eth0.0"
option proto static
option ipaddr '192.168.1.98'
option netmask 255.255.255.0
option gateway '192.168.1.1'
option dns '192.168.1.1'
##### VLAN 2 , Bastenwlan
config interface lan2
option type bridge
option ifname "eth0.2"
option proto static
option ipaddr '192.168.3.2'
option netmask '255.255.255.0'
option dns '192.168.1.1'
option dhcp '192.168.1.1'

thats all

Ein neuer WLAN Router – der WRT160NL

Author: Stephan  |  Category: Linux, Netzwerk, openwrt

Aus verschiedenen Gründen ( Speicher , Gigabit Ports ,.. ) und weil ich einfach auch ein Bastelwlan haben wollte ( das sollte dann der alte Router werden ) musste ein neuer Router her.
Eigentlich wollte ich ja einen , der zwei WLAns simultan kann egal ob physikalisch oder als virtueller Access Point.
Ausserdem sollte am besten Openwrt drauf laufen .
Diesen Alleskönner schien es nicht zu geben weswegen ich einen wrt160N bestellte.
Bekommen hatte ich allerdings einen wrt160NL.

Der Unterschied zwischen den Geräten erschloss sich mir erst beim Stöbern in der englischen wikipedia .
Der wrt160NL hat einen Atheroschip, dies kann VAP ermöglichen !!

Momentan bin ich nach diesem howto dabei, die Firmware zu bauen

Meine bisherigen Schritte

mkdir OpenWrt
cd OpenWrt/
svn co svn://svn.openwrt.org/openwrt/trunk/
cd trunk
svn up

sollte eine Versionsnummer von r17264 oder größer sein

./scripts/feeds update
make defconfig
make package/symlinks
make menuconfig

Im Menü habe ich als Target System ar71xx und als Target Profil wrt160nl eingestellt.
Momentan läuft das

make

noch

Warum WLAN Router übertakten

Author: Stephan  |  Category: Linux, Netzwerk, openwrt

Wie so manch anderer habe ich eine Linux Distribution auf meinen Linux Router , einen Lynksys WRT54G geflasht ( Openwrt)
linksys wrt54g
Nun hatte ich mit manchen clients Verbindungsprobleme und habe gelesen das Übertakten was bringen sollte. Nun , die SB Frequenz ist direkt an die CPU des Routers im Verhältnis 1:2 gekoppelt und dementsprechend profitiert auch die Sendeliestung.

Dazu muß auf der Console folgendes eingegeben werden

nvram set clkfreq=250
nvram commit
reboot